Cisco 837

!
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime localtime show-timezone
service timestamps log datetime localtime show-timezone
service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
memory-size iomem 5
logging buffered 10000 debugging
!
no aaa new-model
clock timezone NZST 12
clock summer-time NZDT recurring 4 Sun Sep 2:00 1 Sun Apr 3:00
no ip source-route
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.100.101.254
!
ip dhcp pool LAN
   import all
   network 10.100.101.0 255.255.255.0
   default-router 10.100.101.254 
   dns-server 58.28.4.2 58.28.6.2 
   lease 0 2
!
!
ip cef
no ip domain lookup
no ip bootp server
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
ipv6 unicast-routing
ipv6 cef
ipv6 dhcp database bootflash
ipv6 dhcp pool dhcp-local
 dns-server 2001:E20:1000:4::2
 dns-server 2001:E20:1000:6::2
 domain-name home.local
!
!
!
!
!
ip tcp path-mtu-discovery
! 
!
!
!
interface Ethernet0
 ip address 10.100.101.254 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 ipv6 address dhcp-prefix ::/64 eui-64
 ipv6 enable
 ipv6 nd other-config-flag
 ipv6 dhcp server dhcp-local
 hold-queue 100 out
!
interface Ethernet2
 no ip address
 shutdown
 hold-queue 100 out
!
interface ATM0
 no ip address
 ip route-cache flow
 no ip mroute-cache
 logging event atm pvc state
 logging event subif-link-status
 no atm auto-configuration
 atm ilmi-keepalive
 no atm address-registration
 dsl operating-mode ansi-dmt
 dsl enable-training-log
 dsl lom 100
 pvc 0/100 
  oam-pvc manage
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !        
!
interface FastEthernet1
 duplex auto
 speed auto
!
interface FastEthernet2
 duplex auto
 speed auto
!
interface FastEthernet3
 duplex auto
 speed auto
!
interface FastEthernet4
 duplex auto
 speed auto
!
interface Dialer0
 ip address negotiated
 no ip unreachables
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 no ip mroute-cache
 logging event subif-link-status
 dialer pool 1
 dialer idle-timeout 0
 dialer persistent
 ipv6 address autoconfig default
 ipv6 enable
 ipv6 dhcp client pd dhcp-prefix
 random-detect 
 no cdp enable
 ppp pap sent-username username@adsl.xnet.co.nz password <whatever>
 ppp ipcp dns request
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
no ip http server
no ip http secure-server
!
ip nat inside source list 1 interface Dialer0 overload
!
access-list 1 permit 10.100.101.0 0.0.0.255
dialer-list 1 protocol ip permit
ipv6 route ::/0 Dialer0
!
!
!
control-plane
!
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 login
!
scheduler max-task-time 5000
end