56 Posts in 20 Topics by 17 members

IPv6 Capable xDSL Devices

Forum » IPv6 Capable xDSL Devices » OpenWRT Help available

Page: 1 , 2 Go to End
Author Topic: OpenWRT Help available 3695 Views

Re: OpenWRT Help available Link to this post

I spent a large part of last night on this and in the end managed to login to ADAM2's ftp and begin the upload. However the progress was *very* slow. It uploaded only ~180kB overnight (8 hrs or so). With tcpdump I could see the ACKs coming back from the router exactly 2 minutes after the respective data packets were sent out. Any idea what's causing this?

Here is my /proc/ticfg/env. Are the values similar to yours?

autoload 1
autoload_timeout 7
BOOTCFG m:f:"mtd1"
bootloaderVersion 1.3.7.15
BUILD_OPS 0x301
cpmac_phy 0
CPUFREQ 211968000
enable_margin_retrain 1
eoc_vendor_id 0x444C696E6B000000
eoc_vendor_revision 20070314
eoc_vendor_serialnum 00:1B:11:3D:8A:3B_00000000000000
FLASHSZ 0x00400000
HWA_0 00:1B:11:3D:8A:3B
HWA_3 01:E0:03:04:05:03
HWA_HRNDIS 00:E0:A9:30:41:E1
HWA_RNDIS 00:E0:A9:30:41:EB
HWRevision Unknown
invntry_vernum 2007031400000000
IPA 5.8.8.8
MAC_PORT 0
MEMSZ 0x01000000
MIPSFREQ 211968000
MODETTY0 38400,n,8,1,hw
MODETTY1 38400,n,8,1,hw
modulation 0xffff
mtd0 0x900a1000,0x90400000
mtd1 0x90020090,0x900a1000
mtd2 0x90000000,0x90010000
mtd3 0x90010000,0x90020000
mtd4 0x90020000,0x90400000
ProductID AR7RD
PROMPT (psbl)
SerialNumber 00:1B:11:3D:8A:3B
StaticBuffer 384
SYSFREQ 105984000
usb_board_mac 00:1B:11:3D:8A:3C
usb_man D-Link
usb_pid 0x5b00
usb_prod DSL-502T
usb_rndis_mac 00:1B:11:3D:8A:3D
usb_serial 00:1B:11:3D:8A:3C
usb_vid 0x2001
vcc_encaps0 0.0
vcc_encaps1 0.0
vcc_encaps2 0.0
vcc_encaps3 0.0
vcc_encaps4 0.0
vcc_encaps5 0.0
vcc_encaps6 0.0
vcc_encaps7 0.0

Re: OpenWRT Help available Link to this post

Sorted. For the record a couple of problems that I had to overcome:

1) My setup originally was a direct connection between laptop's ethernet port and the router. However when I powered down the router the OS on my laptop (OpenSUSE Linux 11.1) detected that the link went down and unconfigured the interface. To prevent the interface from going down with every router restart I used a switch between the router and my laptop. The switch keeps the laptop link up, regardless of what's going on on the router's link.

2) The OS obviously needs to know the router's MAC address before sending anything its way, therefore when "ftp 192.168.1.1" is run it first starts sending ARP requests. However the ADAM2's activity window is too short and before the MAC address is resolved ADAM2 often moved on and booted the D-Link firmware. To overcome this I used a static arp entry:

~# arp -s 192.168.1.1 00:1b:11:2f:9a:0d -i eth0

3) And finally, since all the above still wouldn't lead to an adam2 ftp login I realised that by default its IP address is 5.8.8.8 instead of 192.168.1.1. You can check that also from the D-Link firmware - telnet to the router, login as admin/admin or whatever your webUI password is and have a look at /proc/ticfg/env. Look for 'my_ipaddress' or 'IPA' keys.
This address can easily be changed with:

echo "IPA 192.168.1.1" > /proc/ticfg/env

4) My LFTP client by default negotiates a "passive mode". That causes the really very slow upload I described earlier. Disable passive mode and the speed is suddenly ~40kB/s:

$ ftp 192.168.1.1
Connected to 192.168.1.1.
220 ADAM2 FTP Server ready.
Name (192.168.1.1:user): adam2
331 Password required for adam2.
Password: adam2
230 User adam2 successfully logged in.
Remote system type is UNIX.
ftp> binary
200 Type set to I.
ftp> passive off
Passive mode: off; fallback to active mode: off.
ftp> quote MEDIA FLSH
200 Media set to FLSH.
ftp> put openwrt-ar7-squashfs.bin "fs mtd4"
local: /media/disk/OpenWRT-ar7/bin/ar7/openwrt-ar7-squashfs.bin remote: fs mtd4
502 Command not implemented - Try HELP.
200 Port command successful.
120 service ready in 33 seconds.
100% |************ *******************| 2432 KB 41.47 KB/s 00:00 ETA
150 Opening BINARY mode data connection for file transfer.
2490372 bytes sent in 00:58 (41.47 KB/s)
226 Transfer complete.
ftp> ^D

Now powercycle the router, telnet to 192.168.1.1 and off you go.

BTW YellowOnion - how big is your squashfs image?

Re: OpenWRT Help available Link to this post

Sorted. For the record a couple of problems that I had to overcome:

1) My setup originally was a direct connection between laptop's ethernet port and the router. However when I powered down the router the OS on my laptop (OpenSUSE Linux 11.1) detected that the link went down and unconfigured the interface. To prevent the interface from going down with every router restart I used a switch between the router and my laptop. The switch keeps the laptop link up, regardless of what's going on on the router's link.

2) The OS obviously needs to know the router's MAC address before sending anything its way, therefore when "ftp 192.168.1.1" is run it first starts sending ARP requests. However the ADAM2's activity window is too short and before the MAC address is resolved ADAM2 often moved on and booted the D-Link firmware. To overcome this I used a static arp entry:

~# arp -s 192.168.1.1 00:1b:11:2f:9a:0d -i eth0

3) And finally, since all the above still wouldn't lead to an adam2 ftp login I realised that by default its IP address is 5.8.8.8 instead of 192.168.1.1. You can check that also from the D-Link firmware - telnet to the router, login as admin/admin or whatever your webUI password is and have a look at /proc/ticfg/env. Look for 'my_ipaddress' or 'IPA' keys.
This address can easily be changed with:

echo "IPA 192.168.1.1" > /proc/ticfg/env

4) My LFTP client by default negotiates a "passive mode". That causes the really very slow upload I described earlier. Disable passive mode and the speed is suddenly ~40kB/s:

$ ftp 192.168.1.1
Connected to 192.168.1.1.
220 ADAM2 FTP Server ready.
Name (192.168.1.1:user): adam2
331 Password required for adam2.
Password: adam2
230 User adam2 successfully logged in.
Remote system type is UNIX.
ftp> binary
200 Type set to I.
ftp> passive off
Passive mode: off; fallback to active mode: off.
ftp> quote MEDIA FLSH
200 Media set to FLSH.
ftp> put openwrt-ar7-squashfs.bin "fs mtd4"
local: /media/disk/OpenWRT-ar7/bin/ar7/openwrt-ar7-squashfs.bin remote: fs mtd4
502 Command not implemented - Try HELP.
200 Port command successful.
120 service ready in 33 seconds.
100% |************ *******************| 2432 KB 41.47 KB/s 00:00 ETA
150 Opening BINARY mode data connection for file transfer.
2490372 bytes sent in 00:58 (41.47 KB/s)
226 Transfer complete.
ftp> ^D

Now powercycle the router, telnet to 192.168.1.1 and off you go.

BTW YellowOnion - how big is your squashfs image?

Re: OpenWRT Help available Link to this post

Hi YellowOnion,

I was just giving OpenWRT another try but can't figure out how to set up the ADSL/ppp0 device. "ifup wan" doesn't seem to do anything. Your posted config for "wan" interface refers to "atm0" device - how do I set that up? I've got all the ppp modules loaded but still got no atm0. What else do I need for adsl/ppp0?

Thanks

Re: OpenWRT Help available Link to this post

Ok, all sorted, OpenWRT works for me too :)

Re: OpenWRT Help available Link to this post

OK first Very Sorry, I totally forgot about this forum plus I was stuck with Telecom internet.

second good to hear you got it working :D

Re: OpenWRT Help available Link to this post

Hi

Im also trying to get openwrt going on my DSL-504T Gen2... So far ive only managed to deeply upset it. (it now only powers into ftp mode)

Did you have to change any of the mtd partitions?
Can you advise me what your mtd partitions look like?

Could I get your openwrt image?

Please feel free to e-mail me directly... at myusernicname at hotmail.com

    3695 Views
Go to Top